VPN Maintenance
Incident Report for Wake Forest University
Resolved
The VPN service is now available
Posted Jan 09, 2019 - 18:00 EST
Update
Due to complications, VPN is still down. Estimated time of repair has not been determined.
Posted Jan 09, 2019 - 16:25 EST
Investigating
Due to complication VPN is still down estimated time of repair has not been determined.
Posted Jan 09, 2019 - 16:17 EST
This incident affected: Network (VPN).