WIN - Service Disruption
Incident Report for Wake Forest University
Resolved
WIN is now available.
Posted Mar 16, 2018 - 12:21 EDT
Investigating
We are currently experiencing a service disruption with the Wake Information Network (WIN).

Information Systems is working to identify the root cause and implement a solution.

We will post an update when more information is available.
Posted Mar 16, 2018 - 12:19 EDT
This incident affected: Information Systems (WIN).