AskDeac - Degraded Performance

Incident Report for Wake Forest University

Resolved

Freshservice reported the issue had been resolved and the service is operational: https://updates.freshservice.com/incident/1609547
Posted Aug 31, 2026 - 09:47 EDT

Investigating

Information Systems has identified a service disruption with Freshservice. Since Freshservice is utilized as IS's ticketing system, there may be delays in responses to inquires. Users of Freshservice may experience degraded performance when navigating the platform.

We will post an update when more information is available.
Posted Aug 31, 2026 - 09:18 EDT
This incident affected: Information Systems (AskDeac).