Workday - Intermittent Service Interruption

Incident Report for Wake Forest University

Resolved

This incident has been resolved.
Posted Aug 24, 2026 - 14:48 EDT

Update

While we continue working on a resolution for this issue, please note that if you encounter the "Something went wrong" error, you may still be able to use the Workday menu and search bar to navigate the system and find what you need. We will provide another update as soon as the underlying issue is fully resolved.
Posted Aug 24, 2026 - 09:22 EDT

Identified

Information Systems has identified a service disruption with Workday. Users may see "Something went wrong" messages when attempting to access the system. Workday is actively working to resolve this issue. We will post an update when more information is available.
Posted Aug 24, 2026 - 09:09 EDT
This incident affected: Administrative Technology (Workday).