Kaltura is experiencing issues

Incident Report for Wake Forest University

Resolved

Kaltura has resolve this issue.
Posted Mar 19, 2025 - 14:40 EDT

Investigating

Kaltura is currently experiencing issues and a ticket has been opened with their technical support.
Posted Mar 19, 2025 - 13:24 EDT
This incident affected: Academic Technology (Kaltura).