Stream2 Outage

Incident Report for Wake Forest University

Resolved

Stream2 is operational.
Posted Apr 21, 2025 - 11:23 EDT

Identified

Information Systems has identified an outage with Stream2.

We will post an update when more information is available.
Posted Apr 21, 2025 - 10:12 EDT
This incident affected: Multimedia and Cable TV (Cable TV Network).