The Cable TV for the Miller Center (athletics center) is currently down. Currently, this is impacting cable tv services in the Miller Center, WFDD, and Anthropology.
Incident Report for Wake Forest University
Resolved
All Cable TV functions have been restored.
Posted Apr 18, 2024 - 18:14 EDT
Investigating
We are currently investigating the issue. No ETA for a correction has been provided at this time.
Posted Apr 18, 2024 - 14:28 EDT
This incident affected: Multimedia and Cable TV (Cable TV Network).