Workday Production Unavailable

Incident Report for Wake Forest University

Resolved

Workday is fully functional and working as expected. Please contact the Service Desk if you have any further issues.
Posted Mar 17, 2025 - 17:42 EDT

Monitoring

Workday Production is now available. We will continue to monitor the situation for any further issues.
Posted Mar 17, 2025 - 15:45 EDT

Investigating

Our Workday web portal (in browser) is currently unavailable, however, IS has observed that many are able to access through the Workday mobile app. Workday support teams are working to resolve these issues. IS will update this incident when we have further information.
Posted Mar 17, 2025 - 14:35 EDT
This incident affected: Administrative Technology (Workday).