The fiber cut has been fully repaired and all connections are back to normal.
Posted Aug 01, 2025 - 08:35 EDT
Monitoring
Our internet provider has restored our primary connection. As internet traffic shifts back, there may be brief disruptions in some services as seen previously. We are continuing to monitor the situation closely, as the fiber repair work may still be in progress. Updates will be shared as we receive more information.
Posted Jul 31, 2025 - 12:19 EDT
Identified
Earlier today, some folks may have noticed that certain websites or services were slow to load or didn’t respond right away. This was due to a fiber cut in the Huntersville area that affected one of our main connections to Amazon Web Services (AWS), where many of our systems run. Services were rerouted through a backup connection and are now operating as expected. We are actively monitoring the situation and will share updates as they become available.
Posted Jul 31, 2025 - 11:11 EDT
This incident affected: Network (Wireless connectivity, Wired connectivity).