WFU Google App Launcher - Missing WFU Related Icons

Incident Report for Wake Forest University

Resolved

This has been resolved. If you still do not see the apps, please sign out and back into your account.
Posted Mar 23, 2026 - 17:02 EDT

Update

We are continuing to look into this issue. A full list of your WFU apps are accessible here: https://workspace.google.com/dashboard
Posted Mar 23, 2026 - 10:18 EDT

Investigating

Information Systems has identified a service disruption with the Google App Launcher, where WFU related launchers are missing, including Workday, Canvas and others.

You can still access Workday by going directly to the link: https://www.myworkday.com/wfu
You can still access Canvas by going directly to the link: https://wakeforest.instructure.com/
You can still access Kaltura by going directly to the link: https://wakeforest.mediaspace.kaltura.com/
If you have an MS Office 365 license , you can still access the MS Office 365 portal by going directly to the link: http://portal.office.com/

We will post an update when more information is available.
Posted Mar 23, 2026 - 09:50 EDT
This incident affected: Email Services (G Suite Gmail).