Google Meet - Service Disruption

Incident Report for Wake Forest University

Resolved

This incident has been resolved.
Posted Sep 08, 2025 - 14:47 EDT

Monitoring

Google:
"Our engineers have identified the root cause and rolled back a recent change. Current internal telemetry data indicates that the Google Meet service is operating normally as of 2:18 PM"
Posted Sep 08, 2025 - 14:33 EDT

Identified

Google Meet is currently experiencing a service disruption, which Google has acknowledged and is investigating. The issue does not affect Google Meet used via the Gmail or Meet mobile apps.

As a temporary solution, zoom.wfu.edu is available.

Further updates will be provided as more information becomes available.
Posted Sep 08, 2025 - 14:05 EDT
This incident affected: Multimedia and Cable TV (Google Meet).