Freshservice (IS Ticket System) - Degraded Performance

Incident Report for Wake Forest University

Resolved

This incident has been resolved.
Posted Apr 15, 2026 - 09:14 EDT

Monitoring

A fix has been reportedly implemented and is currently being monitored.
Posted Apr 14, 2026 - 13:12 EDT

Identified

Information Systems has identified a service disruption affecting Freshservice, which we utilize for our ticketing system. This issue is currently impacting our ability to send and receive emails. As a result, there may be a delay in our receipt or response to your inquiries.

Live Status of incident: https://updates.freshservice.com/incident/1606615

While we are still capable of sending and receiving some emails, please use these unaffected channels for urgent requests:

Phone: 336.758.HELP (4357)
Live Chat: help.wfu.edu

We are monitoring the situation closely and will provide an update as soon as service is restored.
Posted Apr 14, 2026 - 09:38 EDT
This incident affected: Information Systems (AskDeac).