AskDeac issue impacting ticket visibility and will cause delay in response times

Incident Report for Wake Forest University

Resolved

This incident has been resolved.
Posted Jul 31, 2025 - 12:14 EDT

Monitoring

Functionality within AskDeac appears to have been restored and agents are once again able to view tickets and emails as expected. We are continuing to monitor the system to ensure stability.

Thank you for your patience while we worked to address the issue.
Posted Jul 31, 2025 - 11:26 EDT

Investigating

We are currently investigating an issue impacting the AskDeac ticketing system. Agents are unable to view most tickets and emails within the platform, which may result in delays responding to submitted requests. We are working with our vendor to resolve this issue.

If you have an urgent need, please contact the Service Desk directly via chat at help.wfu.edu or call 336.758.4357.
Posted Jul 31, 2025 - 09:52 EDT
This incident affected: Information Systems (AskDeac).